Ledger signing issue concerns Rabby wallet only.

Incident Report for Dymension

Resolved

This incident has been resolved.
Posted Dec 12, 2024 - 08:34 UTC

Identified

Users are requested to use MetaMask, until a fix is being pushed by the Ledger team.
Posted Nov 04, 2024 - 13:39 UTC

Monitoring

Funds are safe.

MetaMask and Rabby users are having difficulties signing transactions with Ledger.

Users are requested to temporary use Keplr or Leap where funds are available.
Posted Sep 15, 2024 - 11:50 UTC
This incident affected: Dymension Mainnet (dymension_1100-1) and The Portal.