Celestia bridging nodes malfunction

Incident Report for Dymension

Resolved

This incident has been resolved.
Posted Nov 09, 2023 - 16:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 06, 2023 - 16:02 UTC