Latest MetaMask version has a bug which has broken compatibility with Cosmos based transactions.
Incident Report for Dymension
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 10:56 UTC
Identified
MetaMask team has been notified, users are invited to use Rabby, Keplr or any other wallet until issue is fixed.
Posted Sep 09, 2024 - 08:35 UTC
This incident affected: Dymension Mainnet (dymension_1100-1) and The Portal.